CVE-2013-4549

NameCVE-2013-4549
DescriptionQXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs750141

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phantomjs (PTS)stretch, sid2.1.1+dfsg-2vulnerable
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11vulnerable
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
stretch, sid4:4.8.7+dfsg-11fixed
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2fixed
stretch, sid5.7.1+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phantomjssource(unstable)(unfixed)medium
qt4-x11source(unstable)4:4.8.5+git192-g085f851+dfsg-1low750141
qtbase-opensource-srcsource(unstable)5.1.1+dfsg-6medium

Notes

[wheezy] - qt4-x11 <no-dsa> (Minor issue)
[squeeze] - qt4-x11 <no-dsa> (Minor issue)
https://codereview.qt-project.org/#change,70708

Search for package or bug name: Reporting problems