CVE-2013-4568

NameCVE-2013-4568
DescriptionIncomplete blacklist vulnerability in Sanitizer::checkCss in MediaWiki before 1.19.9, 1.20.x before 1.20.8, and 1.21.x before 1.21.3 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain non-ASCII characters in CSS, as demonstrated using variations of "expression" containing (1) full width characters or (2) IPA extensions, which are converted and rendered by Internet Explorer.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2891-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs729629
Debian/oldoldstablepackage mediawiki is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)squeeze, squeeze (security)1:1.15.5-2squeeze6vulnerable
wheezy (security), wheezy1:1.19.20+dfsg-0+deb7u3fixed
sid, jessie1:1.19.20+dfsg-2.3fixed
mediawiki-extensions (PTS)wheezy (security), wheezy3.5~deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.8+dfsg-2.2medium729629
mediawikisourcesqueeze(unfixed)end-of-life
mediawikisourcewheezy1:1.19.14+dfsg-0+deb7u1mediumDSA-2891-1
mediawiki-extensionssourcewheezy3.5~deb7u1mediumDSA-2891-1

Notes

https://bugzilla.wikimedia.org/show_bug.cgi?id=55332

Search for package or bug name: Reporting problems