CVE-2013-4668

NameCVE-2013-4668
DescriptionDirectory traversal vulnerability in File Roller 3.6.x before 3.6.4, 3.8.x before 3.8.3, and 3.9.x before 3.9.3, when libarchive is used, allows remote attackers to create arbitrary files via a crafted archive that is not properly handled in a "Keep directory structure" action, related to fr-archive-libarchive.c and fr-window.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file-roller (PTS)buster3.30.1-2+deb10u1fixed
bullseye3.38.1-1fixed
bookworm43.0-1fixed
sid, trixie44.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
file-rollersourcesqueeze(not affected)
file-rollersourcewheezy(not affected)
file-rollersource(unstable)3.8.3-1

Notes

[squeeze] - file-roller <not-affected> (Doesn't use libarchive)
[wheezy] - file-roller <not-affected> (Doesn't use libarchive)
http://www.ocert.org/advisories/ocert-2013-001.html

Search for package or bug name: Reporting problems