CVE-2013-5018

NameCVE-2013-5018
DescriptionThe is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly validate the return value of the asn1_length function, which allows remote attackers to cause a denial of service (segmentation fault) via a (1) XAuth username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04, 0x30, or 0x31 character followed by an ASN.1 length value that triggers an integer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)stretch5.5.1-4+deb9u4fixed
stretch (security)5.5.1-4+deb9u6fixed
buster, buster (security)5.7.2-1+deb10u2fixed
bullseye (security), bullseye5.9.1-1+deb11u2fixed
bookworm, sid5.9.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)(not affected)

Notes

- strongswan <not-affected> (Only affects 5.0.4 from experimental)
The PEM aspect is under control of the administrator, so not a security issue
The XAuth / EAP Issue only affects 5.0.3/5.0.4

Search for package or bug name: Reporting problems