CVE-2013-5093

NameCVE-2013-5093
DescriptionThe renderLocalView function in render/views.py in graphite-web in Graphite 0.9.5 through 0.9.10 uses the pickle Python module unsafely, which allows remote attackers to execute arbitrary code via a crafted serialized object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs720454

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphite-web (PTS)bookworm1.1.8-2fixed
sid, trixie1.1.10-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphite-websource(unstable)0.9.12+debian-1720454

Notes

http://ceriksen.com/2013/08/20/graphite-remote-code-execution-vulnerability-advisory/

Search for package or bug name: Reporting problems