CVE-2013-5606

NameCVE-2013-5606
DescriptionThe CERT_VerifyCert function in lib/certhigh/certvfy.c in Mozilla Network Security Services (NSS) 3.15 before 3.15.3 provides an unexpected return value for an incompatible key-usage certificate when the CERTVerifyLog argument is valid, which might allow remote attackers to bypass intended access restrictions via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-23-1, DSA-2994-1
NVD severitymedium (attack range: remote)
Debian Bugs735105

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)wheezy2:3.14.5-1+deb7u5fixed
wheezy (security)2:3.26-1+debu7u5fixed
jessie2:3.26-1+debu8u2fixed
jessie (security)2:3.26-1+debu8u3fixed
stretch2:3.26.2-1.1fixed
stretch (security)2:3.26.2-1.1+deb9u1fixed
buster, sid2:3.33-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssource(unstable)2:3.15.3-1medium735105
nsssourcesqueeze3.12.8-1+squeeze8medium
nsssourcewheezy2:3.14.5-1+deb7u1mediumDSA-2994-1

Search for package or bug name: Reporting problems