CVE-2013-5691

NameCVE-2013-5691
DescriptionThe (1) IPv6 and (2) ATM ioctl request handlers in the kernel in FreeBSD 8.3 through 9.2-STABLE do not validate SIOCSIFADDR, SIOCSIFBRDADDR, SIOCSIFDSTADDR, and SIOCSIFNETMASK requests, which allows local users to perform link-layer actions, cause a denial of service (panic), or possibly gain privileges via a crafted application.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2769-1
NVD severitymedium (attack range: local)
Debian Bugs722338
Debian/oldoldstablepackage kfreebsd-8 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kfreebsd-8 (PTS)squeeze8.1+dfsg-8+squeeze4vulnerable
squeeze (security)8.1+dfsg-8+squeeze3vulnerable
wheezy8.3-6+deb7u1fixed
kfreebsd-9 (PTS)wheezy9.0-10+deb70.7fixed
wheezy (security)9.0-10+deb70.10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kfreebsd-8source(unstable)(unfixed)medium
kfreebsd-8sourcesqueeze(unfixed)end-of-life
kfreebsd-8sourcewheezy8.3-6+deb7u1medium
kfreebsd-9source(unstable)9.2~svn255465-1medium722338
kfreebsd-9sourcewheezy9.0-10+deb70.4mediumDSA-2769-1

Notes

[squeeze] - kfreebsd-8 <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems