CVE-2013-5705

NameCVE-2013-5705
Descriptionapache2/modsecurity.c in ModSecurity before 2.7.6 allows remote attackers to bypass rules by using chunked transfer coding with a capitalized Chunked value in the Transfer-Encoding HTTP header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-34-1, DSA-2991-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity-apache (PTS)wheezy, wheezy (security)2.6.6-6+deb7u2fixed
jessie2.8.0-3fixed
stretch2.9.1-2fixed
buster, sid2.9.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-securitysource(unstable)(unfixed)medium
libapache-mod-securitysourcesqueeze2.5.12-1+squeeze4medium
modsecurity-apachesource(unstable)2.7.7-1medium
modsecurity-apachesourcewheezy2.6.6-6+deb7u2mediumDSA-2991-1

Notes

Upstream commit: https://github.com/SpiderLabs/ModSecurity/commit/f8d441cd25172fdfe5b613442fedfc0da3cc333d
http://martin.swende.se/blog/HTTPChunked.html

Search for package or bug name: Reporting problems