CVE-2013-5718

NameCVE-2013-5718
DescriptionThe dissect_nbap_T_dCH_ID function in epan/dissectors/packet-nbap.c in the NBAP dissector in Wireshark 1.8.x before 1.8.10 and 1.10.x before 1.10.2 does not restrict the dch_id value, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2756-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie, sid1.12.1+g01b65bf-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.2-1medium
wiresharksourcesqueeze1.2.11-6+squeeze12mediumDSA-2756-1
wiresharksourcewheezy1.8.2-5wheezy6mediumDSA-2756-1

Notes

[squeeze] - wireshark <not-affected> (Vulnerable code not present)
https://www.wireshark.org/security/wnpa-sec-2013-55.html

Search for package or bug name: Reporting problems