CVE-2013-5914

NameCVE-2013-5914
DescriptionBuffer overflow in the ssl_read_record function in ssl_tls.c in PolarSSL before 1.1.8, when using TLS 1.1, might allow remote attackers to execute arbitrary code via a long packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2782-1
NVD severitymedium (attack range: remote)
Debian Bugs725359
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
polarssl (PTS)squeeze (security), squeeze1.2.9-1~deb6u1fixed
squeeze (lts)1.2.9-1~deb6u4fixed
wheezy1.2.9-1~deb7u4fixed
wheezy (security)1.2.9-1~deb7u5fixed
jessie, sid1.3.9-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
polarsslsource(unstable)1.2.0-1medium725359
polarsslsourcesqueeze1.2.9-1~deb6u1mediumDSA-2782-1
polarsslsourcewheezy1.2.9-1~deb7u1mediumDSA-2782-1

Notes

https://polarssl.org/tech-updates/security-advisories/polarssl-security-advisory-2013-04

Search for package or bug name: Reporting problems