CVE-2013-6171

NameCVE-2013-6171
Descriptioncheckpassword-reply in Dovecot before 2.2.7 performs setuid operations to a user who is authenticating, which allows local users to bypass authentication and access virtual email accounts by attaching to the process and using a restricted file descriptor to modify account information in the response to the dovecot-auth server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs729063

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)jessie, jessie (security)1:2.2.13-12~deb8u4fixed
stretch, stretch (security)1:2.2.27-3+deb9u2fixed
buster, sid1:2.3.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsource(unstable)1:2.2.9-1low729063

Notes

[wheezy] - dovecot <no-dsa> (Minor issue)
[squeeze] - dovecot <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems