CVE-2013-6385

NameCVE-2013-6385
DescriptionThe form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2804-1, DSA-2828-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal6 (PTS)squeeze, squeeze (security)6.31-1fixed
drupal7 (PTS)wheezy7.14-2+deb7u8fixed
wheezy (security)7.14-2+deb7u10fixed
jessie7.32-1+deb8u3fixed
jessie (security)7.32-1+deb8u4fixed
stretch, sid7.38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium
drupal6sourcesqueeze6.29-1mediumDSA-2828-1
drupal7source(unstable)7.24-1medium
drupal7sourcewheezy7.14-2+deb7u1mediumDSA-2804-1

Notes

https://drupal.org/SA-CORE-2013-003

Search for package or bug name: Reporting problems