CVE-2013-6397

NameCVE-2013-6397
DescriptionDirectory traversal vulnerability in SolrResourceLoader in Apache Solr before 4.6 allows remote attackers to read arbitrary files via a .. (dot dot) or full pathname in the tr parameter to solr/select/, when the response writer (wt parameter) is set to XSLT. NOTE: this can be leveraged using a separate XXE (XML eXternal Entity) vulnerability to allow access to files across restricted network boundaries.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2963-1
NVD severitymedium (attack range: remote)
Debian Bugs731113
Debian/oldstablenot known to be vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lucene-solr (PTS)wheezy, wheezy (security)3.6.0+dfsg-1+deb7u1fixed
jessie, sid3.6.2+dfsg-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lucene-solrsource(unstable)3.6.2+dfsg-2medium731113
lucene-solrsourcewheezy3.6.0+dfsg-1+deb7u1mediumDSA-2963-1

Notes

https://issues.apache.org/jira/browse/SOLR-4882

Search for package or bug name: Reporting problems