CVE-2013-6415

NameCVE-2013-6415
DescriptionCross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2888-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs731288, 731289, 731290
Debian/oldoldstablenot vulnerable.
Debian/oldstablepackage ruby-actionpack-2.3 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie2:4.1.8-1fixed
stretch, sid2:4.1.10-1fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5vulnerable
ruby-actionpack-3.2 (PTS)wheezy (security), wheezy3.2.6-6+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-3.2source(unstable)3.2.16-3+0medium
rails-4.0source(unstable)4.0.2+dfsg-1medium731290
ruby-actionpack-2.3source(unstable)(unfixed)medium731289
ruby-actionpack-2.3sourcewheezy(unfixed)end-of-life
ruby-actionpack-3.2source(unstable)3.2.16-1medium731288
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u1mediumDSA-2888-1

Notes

- rails <not-affected> (vulnerable code not present)
Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems