CVE-2013-6416

NameCVE-2013-6416
DescriptionCross-site scripting (XSS) vulnerability in the simple_format helper in actionpack/lib/action_view/helpers/text_helper.rb in Ruby on Rails 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted HTML attribute.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs731290

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie2:4.1.8-1+deb8u4fixed
jessie (security)2:4.1.8-1+deb8u5fixed
stretch2:4.2.7.1-1+deb9u1fixed
buster2:5.2.2.1+dfsg-1fixed
bullseye, sid2:5.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-4.0source(unstable)4.0.2+dfsg-1medium731290
ruby-actionpack-2.3source(unstable)(not affected)
ruby-actionpack-3.2source(unstable)(not affected)

Notes

- ruby-actionpack-3.2 <not-affected> (vulnerable code not present)
- ruby-actionpack-2.3 <not-affected> (vulnerable code not present)
- rails <not-affected> (vulnerable code not present)
Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems