CVE-2013-6417

NameCVE-2013-6417
Descriptionactionpack/lib/action_dispatch/http/request.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request that leverages (1) third-party Rack middleware or (2) custom Rack middleware. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-0155.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2888-1
NVD severitymedium (attack range: remote)
Debian Bugs731288, 731290
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie2:4.1.8-1fixed
stretch, sid2:4.1.10-1fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5fixed
ruby-actionpack-3.2 (PTS)wheezy (security), wheezy3.2.6-6+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-3.2source(unstable)3.2.16-3+0medium
rails-4.0source(unstable)4.0.2+dfsg-1medium731290
ruby-actionpack-2.3source(unstable)(not affected)
ruby-actionpack-3.2source(unstable)3.2.16-1medium731288
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u1mediumDSA-2888-1

Notes

- ruby-actionpack-2.3 <not-affected> (vulnerable code not present)
- rails <not-affected> (vulnerable code not present)
Starting with 2.3.14.1 rails is a transition package
CVE for incomplete fix for CVE-2013-0155

Search for package or bug name: Reporting problems