CVE-2013-6424

NameCVE-2013-6424
DescriptionInteger underflow in the xTrapezoidValid macro in render/picture.h in X.Org allows context-dependent attackers to cause a denial of service (crash) via a negative bottom value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2822-1
NVD severitymedium (attack range: remote)
Debian Bugs742922
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)squeeze, squeeze (security)2:1.7.7-18fixed
squeeze (lts)2:1.7.7-18+deb6u3fixed
wheezy2:1.12.4-6+deb7u5fixed
wheezy (security)2:1.12.4-6+deb7u6fixed
jessie2:1.16.4-1fixed
stretch, sid2:1.17.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.14.2.901-1low742922
xorg-serversourcesqueeze2:1.7.7-18mediumDSA-2822-1
xorg-serversourcewheezy2:1.12.4-6+deb7u2mediumDSA-2822-1

Notes

Band-aid fix in Wheezy not applicable to upstream code, fixed post-Wheezy
in pixman: http://cgit.freedesktop.org/pixman/commit/?id=5e14da97f16e421d084a9e735be21b1025150f0c
Mark the first post-wheezy xorg-server as a pseudo fixed version

Search for package or bug name: Reporting problems