CVE-2013-6425

NameCVE-2013-6425
DescriptionInteger underflow in the pixman_trapezoid_valid macro in pixman.h in Pixman before 0.32.0, as used in X.Org server and cairo, allows context-dependent attackers to cause a denial of service (crash) via a negative bottom value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2823-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pixman (PTS)squeeze (security), squeeze0.16.4-1+deb6u1fixed
wheezy, wheezy (security)0.26.0-4+deb7u1fixed
jessie, sid0.32.6-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pixmansource(unstable)0.30.2-2medium
pixmansourcesqueeze0.16.4-1+deb6u1mediumDSA-2823-1
pixmansourcewheezy0.26.0-4+deb7u1mediumDSA-2823-1

Search for package or bug name: Reporting problems