CVE-2013-6426

NameCVE-2013-6426
DescriptionThe cloudformation-compatible API in OpenStack Orchestration API (Heat) before Havana 2013.2.1 and Icehouse before icehouse-2 does not properly enforce policy rules, which allows local in-instance users to bypass intended access restrictions and (1) create a stack via the CreateStack method or (2) update a stack via the UpdateStack method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs732033

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heat (PTS)jessie2014.1.3-7fixed
stretch1:7.0.0-4fixed
buster1:9.0.0-2fixed
sid1:9.0.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heatsource(unstable)2013.2.1-1medium732033

Notes

https://launchpad.net/bugs/1256049

Search for package or bug name: Reporting problems