CVE-2013-6427

NameCVE-2013-6427
Descriptionupgrade.py in the hp-upgrade service in HP Linux Imaging and Printing (HPLIP) 3.x through 3.13.11 launches a program from an http URL, which allows man-in-the-middle attackers to execute arbitrary code by gaining control over the client-server data stream.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2829-1
NVD severitymedium (attack range: remote)
Debian Bugs731480
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hplip (PTS)squeeze (security), squeeze3.10.6-2+squeeze2fixed
wheezy, wheezy (security)3.12.6-3.1+deb7u1fixed
jessie, sid3.14.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hplipsource(unstable)3.13.11-2medium731480
hplipsourcesqueeze3.10.6-2+squeeze2mediumDSA-2829-1
hplipsourcewheezy3.12.6-3.1+deb7u1mediumDSA-2829-1

Notes

[squeeze] - hplip <not-affected> (Vulnerable code not present)
https://bugzilla.novell.com/show_bug.cgi?id=853405

Search for package or bug name: Reporting problems