CVE-2013-6441

NameCVE-2013-6441
DescriptionThe lxc-sshd template (templates/lxc-sshd.in) in LXC before 1.0.0.beta2 uses read-write permissions when mounting /sbin/init, which allows local users to gain privileges by modifying the init file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-442-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxc (PTS)wheezy0.8.0~rc1-8+deb7u2vulnerable
jessie1:1.0.6-6+deb8u6fixed
jessie (security)1:1.0.6-6+deb8u2fixed
stretch1:2.0.7-2fixed
buster1:2.0.8-2fixed
sid1:2.0.8-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxcsource(unstable)1.0.0-1unimportant
lxcsourcesqueeze0.7.2-1+deb6u1highDLA-442-1

Notes

getting root on host, if not using unprivileged containers or
restricting the containers with apparmor or selinux.
CVE is kept as no official documentation explicitly document this fact
https://github.com/lxc/lxc/commit/f4d5cc8e1f39d132b61e110674528cac727ae0e2 (lxc-1.0.0.beta2)

Search for package or bug name: Reporting problems