CVE-2013-6460

NameCVE-2013-6460
DescriptionNokogiri gem 1.5.x has Denial of Service via infinite loop when parsing XML documents
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-nokogiri (PTS)stretch1.6.8.1-1fixed
buster1.10.0+dfsg1-2fixed
bullseye, sid1.10.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnokogiri-rubysource(unstable)(not affected)
ruby-nokogirisource(unstable)(not affected)

Notes

- ruby-nokogiri <not-affected> (jruby implementation not shiped)
- libnokogiri-ruby <not-affected> (1.4 and earlier not affected)
https://groups.google.com/forum/#!topic/ruby-security-ann/DeJpjTAg1FA

Search for package or bug name: Reporting problems