CVE-2013-6466

NameCVE-2013-6466
DescriptionOpenswan 2.6.39 and earlier allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon restart) via IKEv2 packets that lack expected payloads.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2893-1
NVD severitymedium (attack range: remote)
Debian Bugs737406
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablepackage openswan is vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openswan (PTS)squeeze (security)1:2.6.28+dfsg-5+squeeze2fixed
wheezy1:2.6.37-3vulnerable
wheezy (security)1:2.6.37-3+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openswansource(unstable)(unfixed)medium737406
openswansourcesqueeze1:2.6.28+dfsg-5+squeeze2mediumDSA-2893-1
openswansourcewheezy1:2.6.37-3+deb7u1mediumDSA-2893-1

Notes

https://libreswan.org/security/CVE-2013-6467/CVE-2013-6467.txt

Search for package or bug name: Reporting problems