CVE-2013-6477

NameCVE-2013-6477
DescriptionMultiple integer signedness errors in libpurple in Pidgin before 2.10.8 allow remote attackers to cause a denial of service (application crash) via a crafted timestamp value in an XMPP message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2859-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)bullseye2.14.1-1fixed
bookworm2.14.12-1fixed
sid, trixie2.14.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsourcewheezy2.10.9-1~deb7u1DSA-2859-1
pidginsource(unstable)2.10.8-1

Notes

[squeeze] - pidgin <no-dsa> (Not suitable for code injection)

Search for package or bug name: Reporting problems