CVE-2013-6479

NameCVE-2013-6479
Descriptionutil.c in libpurple in Pidgin before 2.10.8 does not properly allocate memory for HTTP responses that are inconsistent with the Content-Length header, which allows remote HTTP servers to cause a denial of service (application crash) via a crafted response.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2859-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage pidgin is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze (security), squeeze2.7.3-1+squeeze4vulnerable
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
jessie, sid2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.10.8-1medium
pidginsourcewheezy2.10.9-1~deb7u1mediumDSA-2859-1

Notes

[squeeze] - pidgin <no-dsa> (Not suitable for code injection)

Search for package or bug name: Reporting problems