CVE-2013-6485

NameCVE-2013-6485
DescriptionBuffer overflow in util.c in libpurple in Pidgin before 2.10.8 allows remote HTTP servers to cause a denial of service (application crash) or possibly have unspecified other impact via an invalid chunk-size field in chunked transfer-coding data.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2859-1, DSA-2859-2
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze, squeeze (security)2.7.3-1+squeeze4fixed
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
stretch, jessie, sid2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.10.8-1medium
pidginsourcesqueeze2.7.3-1+squeeze4mediumDSA-2859-2
pidginsourcewheezy2.10.9-1~deb7u1mediumDSA-2859-1

Search for package or bug name: Reporting problems