CVE-2013-6891

NameCVE-2013-6891
Descriptionlppasswd in CUPS before 1.7.1, when running with setuid privileges, allows local users to read portions of arbitrary files via a modified HOME environment variable and a symlink attack involving .cups/client.conf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u6fixed
stretch (security)2.2.1-8+deb9u2fixed
buster2.2.10-6+deb10u4fixed
bullseye, sid2.3.3op2-3+deb11u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssourcesqueeze(not affected)
cupssourcewheezy(not affected)
cupssource(unstable)1.7.1-1

Notes

[wheezy] - cups <not-affected> (Vulnerable code introduced with 1.6.4)
[squeeze] - cups <not-affected> (Vulnerable code introduced with 1.6.4)
https://www.cups.org/str.php?L4319

Search for package or bug name: Reporting problems