CVE-2013-7015

NameCVE-2013-7015
DescriptionThe flashsv_decode_frame function in libavcodec/flashsv.c in FFmpeg before 2.1 does not properly validate a certain height value, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted Flash Screen Video data.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2855-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage ffmpeg is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1vulnerable
squeeze (lts)4:0.5.10-1+deb6u1vulnerable
stretch, sid7:2.7.2-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1+deb8u1fixed
jessie (security)6:11.4-1~deb8u1fixed
stretch, sid6:11.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1medium
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:9.11-1medium
libavsourcewheezy6:0.8.10-1mediumDSA-2855-1

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
ffmpeg fix: https://github.com/FFmpeg/FFmpeg/commit/880c73cd76109697447fbfbaa8e5ee5683309446
libav fix: http://git.libav.org/?p=libav.git;a=commit;h=57070b1468edc6ac8cb3696c817f3c943975d4c1
https://trac.ffmpeg.org/ticket/2844

Search for package or bug name: Reporting problems