CVE-2013-7239

NameCVE-2013-7239
Descriptionmemcached before 1.4.17 allows remote attackers to bypass authentication by sending an invalid request with SASL credentials, then sending another request with incorrect SASL credentials.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2832-1
NVD severitymedium
Debian Bugs733643

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
memcached (PTS)stretch (security), stretch1.4.33-1+deb9u1fixed
buster1.5.6-1.1fixed
bullseye, sid1.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
memcachedsourcesqueeze1.4.5-1+deb6u1DSA-2832-1
memcachedsourcewheezy1.4.13-0.2+deb7u1DSA-2832-1
memcachedsource(unstable)1.4.13-0.3733643

Notes

[squeeze] - memcached <not-affected> (vulnerable code present, but SASL authentication support not enabled)
https://code.google.com/p/memcached/wiki/ReleaseNotes1417
https://code.google.com/p/memcached/issues/detail?id=316
https://github.com/memcached/memcached/commit/87c1cf0f20be20608d3becf854e9cf0910f4ad32

Search for package or bug name: Reporting problems