DescriptionXstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run arbitrary shell commands by manipulating the processed input stream when unmarshaling XML or any supported format. e.g. JSON.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs734821

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxstream-java (PTS)jessie (security), jessie1.4.7-2+deb8u2fixed
bullseye, sid, buster1.4.11.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxstream-javasourcesqueeze(not affected)
libxstream-javasourcewheezy(not affected)


[wheezy] - libxstream-java <not-affected> (Vulnerability introduced in 1.4.5)
[squeeze] - libxstream-java <not-affected> (Vulnerability introduced in 1.4.5)
initial patch:

Search for package or bug name: Reporting problems