CVE-2013-7285

NameCVE-2013-7285
DescriptionXstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run arbitrary shell commands by manipulating the processed input stream when unmarshaling XML or any supported format. e.g. JSON.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs734821

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxstream-java (PTS)buster1.4.11.1-1+deb10u3fixed
buster (security)1.4.11.1-1+deb10u4fixed
bullseye1.4.15-3+deb11u1fixed
bullseye (security)1.4.15-3+deb11u2fixed
bookworm, sid1.4.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxstream-javasourcesqueeze(not affected)
libxstream-javasourcewheezy(not affected)
libxstream-javasource(unstable)1.4.7-1734821

Notes

[wheezy] - libxstream-java <not-affected> (Vulnerability introduced in 1.4.5)
[squeeze] - libxstream-java <not-affected> (Vulnerability introduced in 1.4.5)
http://blog.diniscruz.com/2013/12/xstream-remote-code-execution-exploit.html
http://markmail.org/message/kfqoqdfj5fnup5co?q=list:org.codehaus.xstream.dev&page=3
initial patch: https://fisheye.codehaus.org/changelog/xstream?cs=2210

Search for package or bug name: Reporting problems