CVE-2013-7322

NameCVE-2013-7322
Descriptionusersfile.c in liboath in OATH Toolkit before 2.4.1 does not properly handle lines containing an invalid one-time-password (OTP) type and a user name in /etc/users.oath, which causes the wrong line to be updated when invalidating an OTP and allows context-dependent attackers to conduct replay attacks, as demonstrated by a commented out line when using libpam-oath.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs738515

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
oath-toolkit (PTS)jessie2.4.1-1fixed
stretch2.6.1-1fixed
buster, sid2.6.1-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
oath-toolkitsource(unstable)2.4.1-1low738515

Notes

[wheezy] - oath-toolkit <no-dsa> (Minor issue)
http://lists.nongnu.org/archive/html/oath-toolkit-help/2013-12/msg00000.html

Search for package or bug name: Reporting problems