DescriptionThe CGI::Application module before 4.50_50 and 4.50_51 for Perl, when run modes are not specified, allows remote attackers to obtain sensitive information (web queries and environment details) via vectors related to the dump_html function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs739505

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcgi-application-perl (PTS)wheezy4.50-1vulnerable
buster, sid, stretch4.50-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[wheezy] - libcgi-application-perl <no-dsa> (Minor issue)
[squeeze] - libcgi-application-perl <no-dsa> (Minor issue)
suggested fix

Search for package or bug name: Reporting problems