CVE-2013-7421

NameCVE-2013-7421
DescriptionThe Crypto API in the Linux kernel before 3.18.5 allows local users to load arbitrary kernel modules via a bind system call for an AF_ALG socket with a module name in the salg_name field, a different vulnerability than CVE-2014-9644.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3170-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.76-1fixed
stretch4.9.189-3fixed
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.67-2+deb10u1fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye, sid5.3.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.16.7-ckt4-2
linuxsourcewheezy3.2.65-1+deb7u2DSA-3170-1
linux-2.6source(unstable)(unfixed)
linux-2.6sourcesqueeze(not affected)

Notes

[squeeze] - linux-2.6 <not-affected> (Introduced in v2.6.38-rc1)
https://lkml.org/lkml/2013/3/4/70
https://plus.google.com/+MathiasKrause/posts/PqFCo4bfrWu
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5d26a105b5a7 (v3.19-rc1)

Search for package or bug name: Reporting problems