CVE-2013-7437

NameCVE-2013-7437
DescriptionMultiple integer overflows in potrace 1.11 allow remote attackers to cause a denial of service (crash) via large dimensions in a BMP image, which triggers a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-675-1
NVD severitymedium (attack range: remote)
Debian Bugs778646

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
potrace (PTS)jessie1.12-1+deb8u1fixed
stretch1.13-3fixed
buster, sid1.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
potracesource(unstable)1.12-1medium778646
potracesourcewheezy1.10-1+deb7u1mediumDLA-675-1

Notes

[squeeze] - potrace <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=955808
http://www.openwall.com/lists/oss-security/2015/02/06/12

Search for package or bug name: Reporting problems