CVE-2013-7455

NameCVE-2013-7455
DescriptionDouble free vulnerability in the DefaultICCintents function in cmscnvrt.c in liblcms2 in Little CMS 2.x before 2.6 allows remote attackers to execute arbitrary code via a malformed ICC profile that triggers an error in the default intent handler.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lcms2 (PTS)jessie2.6-3+deb8u1fixed
jessie (security)2.6-3+deb8u2fixed
stretch (security), stretch2.8-4+deb9u1fixed
buster, bullseye2.9-3fixed
sid2.9-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lcms2source(unstable)2.6-1high
lcms2sourcewheezy(not affected)

Notes

[wheezy] - lcms2 <not-affected> (vulnerable code not present, no cmsPipelineFree(Lut); in Error:-part)
https://www.kb.cert.org/vuls/id/369800
https://github.com/mm2/Little-CMS/commit/fefaaa43c382eee632ea3ad0cfa915335140e1db#diff-189a94f0a7a47efdd43f5567e27a973b

Search for package or bug name: Reporting problems