CVE-2013-7456

NameCVE-2013-7456
Descriptiongd_interpolation.c in the GD Graphics Library (aka libgd) before 2.1.1, as used in PHP before 5.5.36, 5.6.x before 5.6.22, and 7.x before 7.0.7, allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a crafted image that is mishandled by the imagescale function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3587-1, DSA-3602-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.1.1-1medium
libgd2sourcejessie2.1.0-5+deb8u3mediumDSA-3587-1
libgd2sourcewheezy(not affected)
php5source(unstable)5.6.22+dfsg-1unimportant
php5sourcejessie5.6.22+dfsg-0+deb8u1mediumDSA-3602-1
php7.0source(unstable)7.0.7-1unimportant

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code not present)
https://github.com/libgd/libgd/commit/4f65a3e4eedaffa1efcf9ee1eb08f0b504fbc31a (gd-2.1.1)
Starting with 5.4.0-1 Debian uses the system copy of libgd
PHP bug: https://bugs.php.net/bug.php?id=72227
Fixed in 7.0.7, 5.6.22, 5.5.36
http://www.openwall.com/lists/oss-security/2016/05/25/3

Search for package or bug name: Reporting problems