CVE-2014-0004

NameCVE-2014-0004
DescriptionStack-based buffer overflow in udisks before 1.0.5 and 2.x before 2.1.3 allows local users to cause a denial of service (crash) and possibly execute arbitrary code via a long mount point.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2872-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
udisks (PTS)squeeze, squeeze (security)1.0.1+git20100614-3squeeze1fixed
wheezy, wheezy (security)1.0.4-7wheezy1fixed
stretch, sid, jessie1.0.5-1fixed
udisks2 (PTS)jessie2.1.3-5fixed
stretch, sid2.1.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
udiskssource(unstable)1.0.5-1medium
udiskssourcesqueeze1.0.1+git20100614-3squeeze1mediumDSA-2872-1
udiskssourcewheezy1.0.4-7wheezy1mediumDSA-2872-1
udisks2source(unstable)2.1.3-1medium

Search for package or bug name: Reporting problems