CVE-2014-0015

NameCVE-2014-0015
DescriptioncURL and libcurl 7.10.6 through 7.34.0, when more than one authentication method is enabled, re-uses NTLM connections, which might allow context-dependent attackers to authenticate as other users via a request.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2849-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)squeeze, squeeze (security)7.21.0-2.1+squeeze8fixed
squeeze (lts)7.21.0-2.1+squeeze12fixed
wheezy7.26.0-1+wheezy11fixed
wheezy (security)7.26.0-1+wheezy13fixed
jessie (security), jessie7.38.0-4+deb8u2fixed
stretch, sid7.43.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.35.0-1medium
curlsourcesqueeze7.21.0-2.1+squeeze7mediumDSA-2849-1
curlsourcewheezy7.26.0-1+wheezy8mediumDSA-2849-1

Search for package or bug name: Reporting problems