CVE-2014-0020

NameCVE-2014-0020
DescriptionThe IRC protocol plugin in libpurple in Pidgin before 2.10.8 does not validate argument counts, which allows remote IRC servers to cause a denial of service (application crash) via a crafted message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2859-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage pidgin is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze, squeeze (security)2.7.3-1+squeeze4vulnerable
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
stretch, sid, jessie2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.10.8-1medium
pidginsourcewheezy2.10.9-1~deb7u1mediumDSA-2859-1

Notes

[squeeze] - pidgin <no-dsa> (Not suitable for code injection)

Search for package or bug name: Reporting problems