CVE-2014-0039

NameCVE-2014-0039
DescriptionUntrusted search path vulnerability in fwsnort before 1.6.4, when not running as root, allows local users to execute arbitrary code via a Trojan horse fwsnort.conf in the current working directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs737495

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fwsnort (PTS)jessie1.6.5-1fixed
stretch1.6.5-4fixed
buster, sid1.6.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fwsnortsource(unstable)1.6.4-1low737495
fwsnortsourcesqueeze(not affected)

Notes

[wheezy] - fwsnort <no-dsa> (Minor issue)
[squeeze] - fwsnort <not-affected> (Vulnerable code not present)
https://github.com/mrash/fwsnort/commit/fa977453120cc48e1654f373311f9cac468d3348

Search for package or bug name: Reporting problems