CVE-2014-0080

NameCVE-2014-0080
DescriptionSQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster2:4.2.10-1fixed
sid2:5.2.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-4.0source(unstable)(unfixed)medium
ruby-activerecord-2.3source(unstable)(not affected)
ruby-activerecord-3.2source(unstable)(not affected)

Notes

- ruby-activerecord-3.2 <not-affected> (affects only rails 4.0.x)
- ruby-activerecord-2.3 <not-affected> (affects only rails 4.0.x)
- rails <not-affected> (affects only rails 4.0.x)

Search for package or bug name: Reporting problems