DescriptionSQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)buster2:
buster (security)2:
bullseye (security), bullseye2:
sid, trixie2:

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
ruby-activerecord-2.3source(unstable)(not affected)
ruby-activerecord-3.2source(unstable)(not affected)


- ruby-activerecord-3.2 <not-affected> (affects only rails 4.0.x)
- ruby-activerecord-2.3 <not-affected> (affects only rails 4.0.x)
- rails <not-affected> (affects only rails 4.0.x)

Search for package or bug name: Reporting problems