CVE-2014-0081

NameCVE-2014-0081
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2929-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablepackage rails is vulnerable.
Debian/oldstablepackage ruby-actionpack-2.3 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8vulnerable
wheezy2:2.3.14.2fixed
jessie2:4.1.8-1fixed
stretch, sid2:4.1.10-1fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5vulnerable
ruby-actionpack-3.2 (PTS)wheezy (security), wheezy3.2.6-6+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14.1medium
railssourcesqueeze(unfixed)end-of-life
rails-3.2source(unstable)3.2.17-1medium
rails-4.0source(unstable)(unfixed)medium
ruby-actionpack-2.3source(unstable)(unfixed)medium
ruby-actionpack-2.3sourcewheezy(unfixed)end-of-life
ruby-actionpack-3.2source(unstable)(unfixed)medium
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u2mediumDSA-2929-1

Notes

[squeeze] - rails <end-of-life> (Unsupported in squeeze-lts)
Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems