CVE-2014-0092

NameCVE-2014-0092
Descriptionlib/x509/verify.c in GnuTLS before 3.1.22 and 3.2.x before 3.2.12 does not properly handle unspecified errors when verifying X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2869-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)squeeze, squeeze (security)2.8.6-1+squeeze3fixed
squeeze (lts)2.8.6-1+squeeze5fixed
wheezy2.12.20-8+deb7u2fixed
wheezy (security)2.12.20-8+deb7u3fixed
gnutls28 (PTS)jessie3.3.8-6fixed
stretch3.3.14-2fixed
sid3.3.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)2.12.23-13medium
gnutls26sourcesqueeze2.8.6-1+squeeze3mediumDSA-2869-1
gnutls26sourcewheezy2.12.20-8+deb7u1mediumDSA-2869-1
gnutls28source(unstable)3.2.11-2medium

Notes

http://gnutls.org/security.html#GNUTLS-SA-2014-2

Search for package or bug name: Reporting problems