CVE-2014-0104

NameCVE-2014-0104
DescriptionIn fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs764801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fence-agents (PTS)stretch4.0.25-1+deb9u2fixed
buster4.3.3-2+deb10u1fixed
bullseye, sid4.5.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fence-agentssource(unstable)4.0.17-1low764801

Notes

[jessie] - fence-agents <no-dsa> (Minor issue)
[wheezy] - fence-agents <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems