CVE-2014-0117

NameCVE-2014-0117
DescriptionThe mod_proxy module in the Apache HTTP Server 2.4.x before 2.4.10, when a reverse proxy is enabled, allows remote attackers to cause a denial of service (child-process crash) via a crafted HTTP Connection header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie (security), jessie2.4.10-10+deb8u12fixed
stretch2.4.25-3+deb9u6fixed
stretch (security)2.4.25-3+deb9u4fixed
buster, sid2.4.37-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.10-1medium
apache2sourcesqueeze(not affected)
apache2sourcewheezy(not affected)

Notes

[squeeze] - apache2 <not-affected> (Affects 2.4.6 to 2.4.9)
[wheezy] - apache2 <not-affected> (Affects 2.4.6 to 2.4.9)

Search for package or bug name: Reporting problems