CVE-2014-0128

NameCVE-2014-0128
DescriptionSquid 3.1 before 3.3.12 and 3.4 before 3.4.4, when SSL-Bump is enabled, allows remote attackers to cause a denial of service (assertion failure) via a crafted range request, related to state management.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs741312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)sid4.1-1fixed
squid3 (PTS)jessie (security), jessie3.4.8-6+deb8u5fixed
stretch (security), stretch3.5.23-5+deb9u1fixed
buster, sid3.5.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(not affected)
squid3source(unstable)3.4.8-1unimportant741312

Notes

- squid <not-affected> (All Squid-3.0 and older versions not vulnerable)
http://www.squid-cache.org/Advisories/SQUID-2014_1.txt
only affects package rebuilds with --enable-ssl by users

Search for package or bug name: Reporting problems