CVE-2014-0133

NameCVE-2014-0133
DescriptionHeap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs742059

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)stretch1.10.3-1+deb9u4fixed
stretch (security)1.10.3-1+deb9u5fixed
buster, buster (security)1.14.2-2+deb10u3fixed
bullseye, sid1.18.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcesqueeze(not affected)
nginxsourcewheezy(not affected)
nginxsource(unstable)1.4.7-1unimportant742059

Notes

[wheezy] - nginx <not-affected> (Vulnerable code not present)
[squeeze] - nginx <not-affected> (Vulnerable code not present)
ngx_http_spdy_module introduced in 1.3.15
Debian compiles with --with-http_spdy_module, but also with --with-debug

Search for package or bug name: Reporting problems