CVE-2014-0138

NameCVE-2014-0138
DescriptionThe default configuration in cURL and libcurl 7.10.6 before 7.36.0 re-uses (1) SCP, (2) SFTP, (3) POP3, (4) POP3S, (5) IMAP, (6) IMAPS, (7) SMTP, (8) SMTPS, (9) LDAP, and (10) LDAPS connections, which might allow context-dependent attackers to connect as other users via a request, a similar issue to CVE-2014-0015.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2902-1
NVD severitymedium (attack range: remote)
Debian Bugs742728
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)squeeze (security), squeeze7.21.0-2.1+squeeze8fixed
squeeze (lts)7.21.0-2.1+squeeze11fixed
wheezy7.26.0-1+wheezy11fixed
wheezy (security)7.26.0-1+wheezy12fixed
jessie, sid7.38.0-4fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.36.0-1medium742728
curlsourcesqueeze7.21.0-2.1+squeeze8mediumDSA-2902-1
curlsourcewheezy7.26.0-1+wheezy9mediumDSA-2902-1

Notes

http://curl.haxx.se/libcurl-bad-reuse.patch

Search for package or bug name: Reporting problems