CVE-2014-0147

NameCVE-2014-0147
DescriptionQemu before 1.6.2 block diver for the various disk image formats used by Bochs and for the QCOW version 2 format, are vulnerable to a possible crash caused by signed data types or a logic error while creating QCOW2 snapshots, which leads to incorrectly calling update_refcount() routine.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3044-1, DSA-3045-1
Debian Bugs742730

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u9fixed
bullseye (security), bullseye1:5.2+dfsg-11+deb11u2fixed
bookworm, sid1:7.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(unfixed)end-of-life
qemusourcewheezy1.1.2+dfsg-6a+deb7u4DSA-3045-1
qemusource(unstable)2.0.0+dfsg-1742730
qemu-kvmsourcesqueeze(unfixed)end-of-life
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u4DSA-3044-1
qemu-kvmsource(unstable)(unfixed)

Notes

[squeeze] - qemu <end-of-life> (Unsupported in squeeze-lts)
[squeeze] - qemu-kvm <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems