CVE-2014-0157

NameCVE-2014-0157
DescriptionCross-site scripting (XSS) vulnerability in the Horizon Orchestration dashboard in OpenStack Dashboard (aka Horizon) 2013.2 before 2013.2.4 and icehouse before icehouse-rc2 allows remote attackers to inject arbitrary web script or HTML via the description field of a Heat template.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs744019

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
horizon (PTS)buster, buster (security)3:14.0.2-3+deb10u2fixed
bullseye3:18.6.2-5+deb11u1fixed
bookworm3:22.1.0-2fixed
sid3:23.0.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horizonsourcewheezy(not affected)
horizonsource(unstable)2013.2.3-1744019

Notes

[wheezy] - horizon <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems